How To Upgrade The Annex Runtime

Amazon Web Services is deprecating support for the Node.js 8.10 runtime, used by condor_annex . If you ran the condor_annex setup command with a version of HTCondor before 8.8.7 or 8.9.5, you should update your account to use the new runtime. Accounts setup with version 8.8.7 and 8.9.5 (or later) of HTCondor will use the new runtime. To update an already-setup account, follow the instructions below.


We've provided a small Python script, upgrade-runtime.py to update your account for you.

  1. Log into the machine where you run condor_annex . If you can't run condor_annex immediately after logging in, do whatever you do so that you can, and then proceed to the next step.
  2. Run
    pip install --user boto3
    This installs a Python library, if it isn't already present, needed by the script.
  3. Download the script:
    wget https://htcondor-wiki.cs.wisc.edu/index.cgi/attach_get/1032/upgrade-runtime.py
  4. Run it:
    python2 ./upgrade-runtime.py

If the script reports a failure, contact us for assistance.

Attachments:

  • upgrade-runtime.py 3487 bytes added by tlmiller on 2019-Nov-25 22:22:05 UTC.
    A script to help users update the condor_annex runtime on AWS.